Installing Flash

I have copied over my Firefox settings from Windows into Iceweasel, starting it up in safe-mode, so I could install Linux extensions, especially NoScript.

I tried installing the flash plugin for Iceweasel, but did not find it in the repository.  A quick search on the Debian forum fixed that problem.  You can install ‘backports’, that is, software that wasn’t meant to be included with Debian Lenny.

To do this, I had to edit /etc/apt/sources.list, adding the following line (as root):

deb http://www.backports.org/debian lenny-backports main contrib non-free

Then you can reload the packages list through synaptic package manager, or enter apt-get update, both commands run as root.  I did find that when I reloaded, I got the following error:

W: GPG error: http://www.backports.org lenny-backports Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY EA8E8B2116BA136C

I decided I can live with that, although I can unselect the backports for most uses of synaptic.

Then you simply install flashplugin-nonfree.

I still do not have any sound from my speakers.  That will be a problem for another day.  What I am aiming for is to use Linux for browsing, email,  and Open Office, and Windows for games.

Advertisements

Tags: ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: